My questionsLogin to ask a question, or to update and review your existing support tickets To my questions
My Account Login and make changes to your Uplay account To my account
Uplay Shop Visit our Online Shop to purchase goodies (including strictly limited or exclusive editions of our products) or if you need help with your Uplay Shop order To the Uplay Shop

Multiplayer Connection Issues in Assassin's Creed III

Answer ID 000016861 | 3/29/2013 9:48:53 AM

Question

ImageMultiplayer connection setup in Assassin’s Creed III

Answer

If you are receiving any multiplayer connection issues, or are having trouble connecting to a game please try the following:

1. Start by updating any anti-virus or personal firewall software that may be installed to your computer system. This includes your windows firewall as well as updating the firmware for your home router. If updating these programs does not resolve the issue, you may need to temporarily shut-down the associated program or bypass the router and establish a direct connection to your modem.

 

2. If it is not possible to shut-down your firewall, you will need to configure your router or firewall to allow the following network ports for the best possible connection:
 

Assassin's Creed III Ports:
TCP (remote port): 80, 443
UDP (local port): 3074

Uplay Launcher:
TCP: 13000, 14000, 14008

Directions for configuring network ports are specific to the software and hardware being used, and can be found by visiting the manufacturers website.

3. You may also encounter problems due to applications running in the background on your computer system. When playing Ubisoft games, please be sure to close all running background applications before starting your game. You can find the steps for this listed below.

- Open your start menu and look for Run (Win XP), Start search (Win Vista), or Search programs and files (Win 7)
- Delete anything on the Open line that you'll find there, and type in the word MSCONFIG and press the Enter key to bring up the system configuration utility
- Look down the list of startup items (not the tab labeled Startup), and choose Selective Startup (if it is not already selected) (If you don't see this, make sure you've clicked on General, near the top of the window)
- Once you've chosen Selective Startup, uncheck 'Load Startup Items'
- Once you're done here, click Apply & OK, and let it reboot your computer

Try running the game again. If the game loads and seems to be working, the problem is most likely related to one or more programs you have scheduled to load with Windows. You can then revert the settings back the way they were, and in a trial and error fashion, disable some programs using the startup tab (in the msconfig utility) to try to find the culprit.

*Keep in mind that this is a temporary solution and any changes can be reverted by returning to the MSCONFIG utility and re-selecting 'Normal Startup"

4.There may also be certain restrictions set by your ISP. If you continue to have trouble, please contact your ISP for details on any specific restrictions on the previously mentioned network ports.

5. Try cleaning your HOSTS file by clicking on the Fix it button on the article found here.

If you continue to have trouble, please use the Ask a Question button at the top of the page to submit a support ticket. Please include a full description of your problem along with any error messages you may have received.