Manually Installing Patch v2.1

QUESTION:

My game is not updating automatically, how can I manually install the Heroes of Might & Magic 6 v2.1 patch?

ANSWER:


We are aware that some users are experiencing difficulties with the auto patching system. In order to fix this issue, we strongly recommend that you follow the steps below:

How to update your game (all versions) to the 2.1.0 version:

Uplay version
  1. Launch Uplay and open the My Games section.
  2. Click on the Heroes of Might & Magic VI shortcut (this may look like a Shades of Darkness icon or a Heroes VI standard one, but it is the same game), to launch the game.
  3. Confirm that you are using a 1.8.0 version (Heroes VI: Standard, Deluxe & Gold editions) or 2.0.0 (Complete Edition, Shades of Darkness standalone) in the lower right corner of the main menu, and then exit the game.
If you are not at v1.8.0 or v2.0.0, you may need to launch the game a few more times, until you are updated to the correct version.

4. Download and install the v2.1 patch directly from these links, be careful to select the appropriate one for your version:

DIGITAL download version (English/French/Italian/German/Spanish) 

RETAIL version (English/French/Italian/German/Spanish) 

5. Launch the game; you should now be on the 2.1.0 version.
If you receive a Shades of Darkness is not installed message when trying to update, please follow this procedure:
If your game is on the 1.8 version and you can't install the v2.1 patch because of this error, you may have downloaded the wrong patch. Please note the difference between the Digital and Retail patch links. If you have downloaded & installed your game from a digital installer (Uplay Shop, non-Steam digital retailer, etc), you have to download the Digital one. If you have installed your game from a disc, you need to install the Retail patch. If you continue getting this error, please make a support ticket Here and a representative will assist you as soon as possible.

Steam version

Auto patching should be working fine on the Steam platform, just launch the game and you will be on the 2.1 version (you can check it on the main menu at the bottom right hand corner of the game).

If your game still shows v1.8.0 at the bottom right hand corner of the menu, please follow this procedure:
  1. Delete the Installscript.vdf file in the Heroes VI install folder (by default: C:\Program Files (x86)\Steam\steamapps\common\Might and Magic Heroes VI). ***Do not erase any other files
  2. In Steam, right click on the Heroes VI game in your library, go to properties -> local files tab and click on Verify integrity of game cache. After this, your game should be on the 2.1 version.
 
How to unlock contents 
  1. Launch the game and select Unlock content on the main menu.
  2. Click on the Unlock button at the bottom of the screen (or any other).
  3. Enter your key and press the Accept button.
  4. Your content is now unlocked

Please note: If you bought the original game from Steam, and Shades of Darkness from another platform/retail (or the other way around), we deeply apologize but you will not be able to merge those versions. You will however, be able to play each game on their dedicated platform.

Associated Platforms

WAS THIS HELPFUL?

Thanks for your feedback. Thanks for your feedback. Sorry that didn't help.
Please submit a support ticket and tell us how we can help you.