Supported Devices for Might & Magic: Elemental Guardians

QUESTION:

iOS Devices
Android Devices

ANSWER:


iOS Devices
iOS 9.1 or above required

iPhone 5, 5C, 5S, SE, 6, 6Plus, 6S, 6S Plus, 7 and 7 Plus 
iPad 3 and 4 
iPad Air and Air2 
iPad Mini 2, 3 and 4
iPad Pro 9,7’’ and iPad Pro 12,9’’

Languages: English


Android Devices
Android 4.3 or above required

Acer Iconia Tab 8 (X86)
Fuhu nabi DreamTab HD8 (X86)
Google Nexus 5
Google Nexus 5X
Google Nexus 6
Google Nexus 6P
Google Nexus 7 2012
Google Nexus 7 2013
Google Nexus 9
Google Pixel C
HTC One M9
HTC One
HTC One M8
HTC 10
LGE G2
LGE G3
LGE G4
LGE Gpad
LGE Gpad
LGE LG G5
Motorola Moto X
Motorola Moto E
Motorola Motorola G
Nvidia SHIELD Tablet
RCA 7 Voyager
Samsung Galaxy Note II
Samsung GALAXY Note3
Samsung GALAXY Note3
Samsung Galaxy Note4 (Int)
Samsung Galaxy Note4 (Thailand)
Samsung Galaxy S III
Samsung Galaxy S III
Samsung Galaxy S III Mini
Samsung GALAXY S4
Samsung Galaxy S4 mini
Samsung Galaxy S5 LTE
Samsung Galaxy S6
Samsung Galaxy Tab4
Samsung Galaxy Tab4 7.0
Samsung Galaxy TabS 10.5
Samsung Galaxy Tab A 9.7
Samsung Galaxy Note 5
Samsung Galaxy S7
Samsung Galaxy S7
Sony Xperia Z
Sony Xperia Z1
Sony Xperia Z2
Xperia Z5
Xiaomi Mi 5

Languages: English
Your device may still be compatible even though you cannot find it in the list above. To try, visit the Google Play Store from the link provided and log in with your Google account. If your device is linked to your Google account, the game page will tell you whether or not it is currently compatible.
 

Associated Platforms

WAS THIS HELPFUL?

Thanks for your feedback. Thanks for your feedback. Sorry that didn't help.
Please submit a support ticket and tell us how we can help you.

RELATED FAQs

No FAQs exist on your locale for this search criteria, here are some from another one.